Menu

Reply To: Tips & Tweaks: Lx3, Lx4, Lx5 modes

Home Forums OSSC OSSC – Discussion and support Tips & Tweaks: Lx3, Lx4, Lx5 modes Reply To: Tips & Tweaks: Lx3, Lx4, Lx5 modes

#11428

Harrumph
Participant

So here’s the story. I had x3 working since before, and managed to get x4 working, as described in the OP. Now I was wondering, why is x5 giving trouble, and why had x2 with 60Hz always had problems (only semi-stable image, that cut in and out)?

I looked at the horizontal samplerate of x3 and x4. It struck me the samplerate was proportional to the linemode (quite logical perhaps). (this is all generic mode btw, didn’t have time to look into optimized yet)

1170/3 = 1560/4= 390. So if I extend this to x2 and x5: 780/2 = 1950/5 = 390
Also, the ratio of samplerate to active was the same in x3 and x4: 1170/960 = 1560/1280 = 1,21875

So by this logic, x2 & x5 could be 780/640 and 1950/1600= 1,21875, for samplerate/active.

Previously these had been 858/720 and 2046/1536, respectively.

Bam! It worked. 🙂

Well, not quite. For x2 I had to use 781.

So in practice, I had swapped from 480p (720×480) to VGA, and to 1600×1080 instead of 1536×1080 (inside the full 1920 horizontal, using regular 1920×1080 output mode here). This makes the aspect slightly wide for x5 mode, but I’m willing to make that sacrifice.

To center the image, I fiddled with sync and backporch only slightly. For the x2 mode I arrived at the nice and even H Sync 50 and H Backporch 70. Scaling these up to the other modes worked very well.

Here’s my final settings

              | x2  | x3   | x4   | x5   |
H Samplerate  | 781 | 1170 | 1560 | 1950 |
H Active      | 640 |  960 | 1280 | 1600 |
H Sync        | 50  |   75 |  100 |  125 |
H Backporch   | 70  |  105 |  140 |  175 |

@bonzobits Don’t understand why you need to correct the aspect ratio in 320 optimized. 320×4=1280 so should fit nicely in the 1280×1024 frame (1280:960 = 4:3).

@arovane As x3 and x4 didn’t work for you previously, I’m afraid this fix for x2 and x5 probably won’t work for you either. 🙁

Bonus tweak: I got PAL 720p generic working by reducing V.Active from 288 to 240, and then increase V.Backporch to 42.

  • This reply was modified 6 months ago by  Harrumph.