Menu

Reply To: Auto sync mode selection

Home Forums OSSC OSSC – Feature Requests Auto sync mode selection Reply To: Auto sync mode selection

#18701

paulb_nl
Participant

So, when you’re on a given input and the OSSC loses sync (such as during a mode change), and you’ve got ‘Autodetect input’ set to ‘All inputs’, the auto input switching starts scanning all inputs for a signal? So if I have two consoles connected, and one of them does a mode change, it will switch to the other console?

I have thought about that but then I thought who has 2 consoles turned on at the same time? 😛 If it is a mode change on the same sync input so for example AV1 RGBS 240i->480i or AV2 YPbPr 480i->480p then the change is instant so auto input scanning does not have time to kick in. Only on something like AV1 RGBS -> RGsB.

If so, how much more complicated would it be to start with the ‘Current input’ behavior and fall back to the ‘All inputs’ after 1 or 2 seconds?

That’s a good idea. I have added that so now after it loses sync it will stay on the Current input behavior for a short time before changing to other inputs.

Also, how complicated would it be possible to hijack Button 0 functionality when Autodetect Input is enabled, so that pressing it triggers a kind of seek-next functionality? (Not unlike how modern radios can automatically seek to the next station with a decent signal.)

Its probably a better idea to use an unused button like the Right arrow. What is your use-case for seek-next functionality? Currently if you use the 1,2,3 buttons it will work like seek-next depending on which input is active.

I encountered a bug where a lot of times the OSSC will not report the correct info on the display after auto switching input. On my NTSC SNES it sometimes even chose the 288p PAL mode. This might be related to the speed of switching but it also happens sometimes when I change the input manually. I’ll have to spend time debugging it.

Ok so my SNES is actually outputting 288p at 60.55Hz. Apparently it chose to break down when I was testing the auto switching. The pin for 50/60Hz was broken long time ago so I just need to fix that again. It wasn’t caused by the auto switching.