Menu

1920×480/1920×576 output

Home Forums OSSC OSSC – Feature Requests 1920×480/1920×576 output

This topic contains 6 replies, has 3 voices, and was last updated by  Thomago 1 month ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #9391

    Thomago
    Participant

    Welp… should have seen that coming.

    So my monitor – an iiyama ProLite XB2783HSU – sucks at processing 480p/576p, as there’s no way to get the aspect ratio right for 4:3 stuff (I have the choice between an “Aspect Mode”, that upscales these resolutions as if they had square pixels, or a “Full Mode”, that stretches them to fill the screen).

    The – according to my monitor – 1440×480/1440×576 resolutions the OSSC outputs if TX mode is set to “DVI” and 480i/576i passtrough to “On” are generally upscaled to fill the screen, so no salvation there.

    Btw, other users seem to have similarly uncooperative monitors: Click me!

    I have experimented with my graphics cards’s custom resolution tool and lo and behold:

    1920x480

    1920x576

    The monitor can display both 1920×480@60Hz and 1920×576@50Hz (1920×480@50Hz unfortunately doesn’t seem to work) and upscales them to fill the screen.

    Would it be possible to make the OSSC output these modes? Together with an option to toggle between 16:9 (image fills the screen) and 4:3 (image is mapped to 1440×480/576, as seen in DVI+480i/576i passthrough mode) these would solve this particular problem and AND provide the means to achieve a maximum horizontal definition for all users with compatible displays.

    • This topic was modified 1 month ago by  Thomago.
    #9394

    paulb_nl
    Participant

    With the timing tweaker you can change the sampling rate to output 1920 horizontal but mapping to 4:3 in 480p mode is not implemented. I had it output 1920x720p in lineX3 4:3 that worked.

    Maybe when lineX4 is added there will also be a 4:3 option like with lineX3.

    #9395

    Thomago
    Participant

    How did you do that exactly? I tried to, but all I got was a black screen…

    • This reply was modified 1 month ago by  Thomago.
    #9397

    paulb_nl
    Participant

    When you increase the sampling rate you also have to increase the h.synclen and h.backporch. For 1920×720 with lineX3 4:3 I ended up with h.samplingrate 1830, h.synclen 43, h.active 1440, h.backporch 255. I couldn’t get the image perfectly centered because the h.backporch maxes out on 255. It needs to be higher.

    #9403

    Thomago
    Participant

    Thanks a bunch! Minipulating the linetriple mode’s timing worked out here as well (didn’t try that before).
    However, trying to enable 1920×576 (coming from the standard 576i settings) ended in a black screen; I guess the sampling rate’s maximum (2300) isn’t sufficient for that to work out. Well… I guess even if it had worked out, I would have ended up with a 16:9 image.

    • This reply was modified 1 month ago by  Thomago.
    #9463

    marqs
    Participant

    One possible solution could be setting H.active to 640 so that monitor should only process 640×480 area (instead of 720×480) of the output.

    LineX3 4:3 has a fixed-size pillarboxes which explains why image can’t be fully centered if width is increased a lot. There’s no similar setting to 480i/480p as number of FPGA PLLs is limited and most displays (well, at least TVs) can size the signal correctly to 4:3.

    #9467

    Thomago
    Participant

    “One possible solution could be setting H.active to 640 so that monitor should only process 640×480 area (instead of 720×480) of the output.”

    That indeed helps with the aspect ratio, but in return is detrimental to image definition :-/

    “as number of FPGA PLLs is limited”

    What exactly does that mean? Is the OSSCs number of output modes limited?

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.