Menu

320×240 optimized always fuzzy

Home Forums OSSC OSSC – Discussion and support 320×240 optimized always fuzzy

This topic contains 5 replies, has 4 voices, and was last updated by  Harrumph 3 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #9979

    HDL
    Participant

    I’ve read that you have to adjust the sample phase when using this mode and find the sweet spot. I’ve tried every possible sample phase setting but there is always a small region of the screen that has some kind of fuzziness effect. Is this just incompatibility with my monitor?

    #9982

    marqs
    Participant

    Which console/game are you using that with? Default parameters are set for PSX 320×240 mode, most likely you need to also tweak H.samplerate for other sources, see examples here

    #10028

    HDL
    Participant

    I’m using NTSC Genesis. I played with the H.samplerate on 240p_L3M2 and it seems 427 does the trick. However it seems like 320×240 optimized mode cuts off part of the overscan on the right side. Any way to prevent that?

    Edit: Seems like the H.active option is meant to address this, but I’m seeing discrepancies between the 240p test suite and actual gameplay with Generic 4:3 mode. In Generic 4:3 the full overscan in shown on the right, but in 320×240 optimized it will still get cut off even if I adjust the H.active value to make the overscan appear in the 240 test suite overscan test. You can also see this in the grid test by turning on the gray background.

    • This reply was modified 6 months, 3 weeks ago by  HDL.
    • This reply was modified 6 months, 3 weeks ago by  HDL.
    #10037

    paulb_nl
    Participant

    Actually you should adjust H.synclen and H.backporch for that. Genesis seems to have 320 and 256 pixel horizontal output modes so maybe the game is using the 256 pixel mode.

    #11786

    HDL
    Participant

    A little late on this, but here’s what I mean about the overscan.

    Left and right sides cut off.

    Here are the settings I changed:

    240p_L3M2
    H.samplerate 427
    H.backporch 55

    Those settings produce this:

    This is how it should look:

    There should be a total width of 348 (28 additional pixels on top of the game’s 320 pixel width). I want this to show up on the OSSC, but if I change H.active to 348 it borks the aspect ratio.

    • This reply was modified 3 months, 2 weeks ago by  HDL.
    • This reply was modified 3 months, 2 weeks ago by  HDL.
    • This reply was modified 3 months, 2 weeks ago by  HDL. Reason: Added more images and info
    #11807

    Harrumph
    Participant

    If your display cannot handle the 348 multiple, then no. The reason you can see it in generic mode is because it uses a multiple of the pixel aspect corrected horizontal length, 390. (427*(32/35) = 390.4)
    Personally, I see no reason for that area to be visible anyway.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.