Menu

50Hz Atari Jaguar

Home Forums OSSC OSSC – Discussion and support 50Hz Atari Jaguar

This topic contains 4 replies, has 3 voices, and was last updated by  BuckoA51 9 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #10848

    Lukemcc
    Participant

    I’ve just updated my OSSC firmware from 0.73 to 0.75 and decided to test my 50hz Jaguar through it and it now works perfectly without changing any of the default settings. Not sure if anyone else has found this already but last i checked (0.73) it wasn’t so for all the many many Jaguar users out there 😉 it now works without doing the 60hz mod.

    #10853

    BuckoA51
    Keymaster

    Nice. I was just about to put my Jaguar away (I’ve run out of room and wanted to put my PS-IO equipped PS1 there instead), but I’ll give it a test before it goes away and report back. Is that connecting the jag via SCART or to D-Sub15 via an adapter btw?

    #10856

    Lukemcc
    Participant

    Connected via scart.

    I really want to get myself a PS-IO, but whenever orders open it’s normally in the middle of the night and by the time i get up and check they are closed again. How are you finding it, is it worth getting one?

    #10868

    marqs
    Participant

    There’s no changes between v0.73 and v0.75 which should have improved handling of sources with problematic sync (VSM=2). The only thing that I can think of making difference is that v0.75 changed default Analog sync LPF to maximum.

    #10875

    BuckoA51
    Keymaster

    I tried my Jaguar and it definitely still has problems getting a stable sync, though switching to an active input on AV3 then back again to AV1 managed to get it to sync. I’d still recommend connecting to AV3 if PAL Jaguar games are your thing, this is much less problematic.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.