Menu

Compatible SD cards

Home Forums OSSC OSSC – Discussion and support Compatible SD cards

This topic contains 9 replies, has 7 voices, and was last updated by  BuckoA51 2 weeks, 3 days ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #7693

    BuckoA51
    Keymaster

    As users are discovering, the OSSC is somewhat fussy as to which SD cards work and which don’t. Typically, standard MicroSD cards of 2gb or less work fine, while MicroSD HC cards do not. Obviously OSSC does not need a high capacity card, but these are so prevalent now that some folks don’t have anything else.

    Post in this thread any SD card that is confirmed working. With a link if possible.

    Confirmed working cards

    2GB MICRO SD MEMORY CARD (generic, bootleg?) http://www.ebay.com/itm/281425331055
    Sandisk Premier TF 2GB MicroSD

    #8643

    coderkind
    Participant

    64GB Transcend didn’t work with firmware updating; just ordered this (before seeing this page), so will update when it’s delivered + tried: https://www.amazon.co.uk/gp/product/B000X4B30O/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

    #8666

    Calle W
    Participant

    coderkind – I just updated my OSSC with that exact card. First the OSSC said the image was invalid but it worked after about a minute or so.

    #8688

    cleeg
    Participant

    Just a quick tip that will be useful I reckon: I tried updating to 0.72FW with a micro SD class 10 SP branded card (came free with my WikiPad, unsure if the SP is a brand, but it looks like it is). I used Win32DiskImager as on the YT vid posted by our host.

    The card was not detected by the OSSC.

    The tip is this: Windows wouldn’t read the card afterward. I couldn’t format the conventional way so tried programs and all kinds of other stuff (typing in that black box, I forget what it’s called – I know, my IT skills are astounding!) when I came across this…

    If your card is borked like mine simply put it in your Canon camera (others may work, but mine’s a Canon and so was the one in the example I found online) and select ‘low level format’ and after putting it back in the PC you should have a working SD again.

    I tried the whole FW procedure again with the same result, and the low level format worked a second time; though on this occasion I also had to have the camera do another, non low level format to have windows detect the device.

    Hope this helps someone, it helped me regain 16GB!

    #8691

    Harrumph
    Participant

    Updated using Transcend MicroSD 2GB TS2GUSD, no problems.

    Bought mine from Komplett.se But also plenty of sellers on Ebay

    #8693

    coderkind
    Participant

    @calle-w; yup. The card just worked for me too.

    Formatted the card in Windows, then used Win32DiskImager to write the image to the micro SD.

    #8977

    h1ghju1ce
    Participant

    I cant seem to get the FW to update, it keeps saying: “Invalid CRC”

    I’m using the same 2GB Sandisk card that coderkind linked to, and I’ve tried 2 different USB-Card readers just incase
    it was that.

    I’ve CLEANed the disk using Diskpart (cleeg – this is what your camera is effectively doing, formatting it to FAT32)

    any other suggestions?

    (I guess I could try my work laptop (win8.1) and see if that cardreader makes any difference…)

    Whats the MD5 hash of the BIN file? (0.73) just so I can be sure its atleast downloading correctly

    thanks

    #8998

    h1ghju1ce
    Participant

    Just got it working, but this time I used the built in SD slot on my laptop (Ricoh chipset, Lenovo X1 Carbon)

    but also I’d downloaded the latest Win32DiskImager 0.95, and its running Win8.1, so all 3 aspects of the process are different

    ———————-
    Setup that didnt work:

    USB -> MultiCard reader (Transcent USB3, and Integreal USB2)
    Win10
    DiskImager v0.7
    ———————-

    #11084

    JDH
    Participant

    Got this one here: http://www.ebay.ca/itm/201648280342?_trksid=p2060353.m2749.l2649&var=500910639741&ssPageName=STRK%3AMEBIDX%3AIT (eBay.ca link)

    Word of warning, I can’t vouch for how “new” this is, as the SD Adapter had bent pins and no packaging, although the MicroSD was perfectly fine. It worked for me, and the price is right.

    Also, Mac users rejoice, I posted how you can create a bootable SD image using Terminal to update firmware using an already existing guide [originally for Raspberry Pi images] (can’t take full credit!) https://www.videogameperfection.com/forums/topic/how-to-update-firmware-using-a-mac/

    Good luck!

    #11692

    BuckoA51
    Keymaster

    Going to unsticky this now as all SD cards should be compatible on the newer firmwares.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.