Menu

Dreamcast blue screen VGA

Home Forums OSSC OSSC – Discussion and support Dreamcast blue screen VGA

This topic contains 7 replies, has 5 voices, and was last updated by  SRRAE 8 months, 2 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #18930

    Wilco
    Participant

    My OSSC has just experienced a bit of a meltdown and I’m wondering if anyone else has had this fault. I was experiencing a bit of noise through the picture when running through the OSSC’s VGA input so I decided to check the cable by running my Dreamcast straight into the VGA input on my monitor. The picture was perfect with no visible noise, I then reattached my cable to the OSSC and now everything on the screen has a blue tint. I then tested the Scart input with m Gamecube and that was fine. I detached and reattached the VGA and the problem of the blue screen still remains. Is this a hardware failure of the VGA port? has anyone else had this problem. I bought my OSSC back in July, would I still be covered by my warranty if it is a manufacturing fault?

    Cheers.

    #18936

    SRRAE
    Participant

    It looks like the VGA port has lost red. Do things on the screen which should be red look black?

    #18939

    Wilco
    Participant

    Yeah? Is that a problem that a novice could fix or do you think i’d need to return it? Yeah, the Red is showing as black. The flickering still remains as well so I imagine this problem is also connected to that.

    #18940

    nmalinoski
    Participant

    Depends by what you mean by “a novice”; a soldering novice could likely fix the problem, assuming it’s just a bad through-hole joint.

    #18941

    Wilco
    Participant

    I’d probably prefer to return it for a fix rather than risk buggering it up any more with my lackluster soldering skills. I’ll contact Bucko and see if I’m still under warranty. Cheers for your help 🙂

    #18945

    timson72
    Participant

    Just tested my Dreamcast and it’s the same through VGA.

    #18957

    JoeTheUseless
    Participant

    You get 1 years warranty with the OSSC so don’t worry just issue a replacement. I have read about this issue before and the last person had to do a return 🙂

    #18970

    SRRAE
    Participant

    Take a look at my post a few months ago.

    VGA input seems to have lost red

    This is what happened to mine. It looks almost exactly the same

    Mine was replaced and was a very quick turnaround.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.