Menu

Firmware v0.80

Home Forums OSSC OSSC – Discussion and support Firmware v0.80

This topic contains 14 replies, has 12 voices, and was last updated by  mrblack1 3 months, 1 week ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #19786

    marqs
    Participant

    Firmware v0.80 is out:

    * PCM1862 audio ADC parameters corrected (fixes audio quality issues with certain systems, e.g. some MD units)
    * audio gain setting added (pre-ADC, +-12dB range)
    * video test pattern updated (32 step grayramp)
    * profile link option added (allows binding a profile to each logical input)

    #19795

    nmalinoski
    Participant
    #19800

    James-F
    Participant

    Thank you!

    Friends don’t forget to create a “OSSC Settings.txt” on you computer and save your hours of tweaking.
    Like so:

    240p Linex3 (960x240)
    ---------------------
    H. Samplerate : 1254
    H. Synclength : 54
    H. Backporch  : 174
    H. Active     : 960
    V. Synclength : 3
    V. Backporch  : 15
    V. Active     : 240
    #19802

    SirRockALot
    Participant

    Maybe marqs should add password saves to the OSSC 😉

    #19825

    jonlad
    Participant

    Updated! Works great, thanks for working on that Marqs.

    But good grief, what a pain in the arse to write down all settings from each profile and then enter back in….

    #19830

    paulb_nl
    Participant

    Thanks again Marqs!

    #19831

    Damn-Deal-Done
    Participant

    This has fixed the odd digital noise for me. VA1 NTSC-J Mega Drive. Thanks

    #19859

    polyh3dron
    Participant

    I can’t wait to try this with my SNES Jr / SD2SNES combo to see if it fixes the noise.

    #19882

    mcmarty
    Participant

    Hi,

    I have just updated to 0.80a and my OSSC has stopped reacting to my remote control commands.

    The green led flashes when a command is sent but the OSSC does nothing.

    The remote is working fine and I have double checked using my Harmony remote to no avail.

    The OSSC is still passing through signals from all inputs and the on board buttons are cycling through the inputs without any problems.

    Has anybody else had a similar problem?

    Is there anyway to rollback the firmware without a remote?

    Any assistance would be gratefully received!

    Oh, first post as well, hello everyone 🙂

    #19894

    mcmarty
    Participant

    Hello again,

    I managed to fix the problem by holding down BTN1 at power on and then re-training the OSSC’s remote commands.

    Perhaps I should have done a tad more research before my panic stations post above!

    Phew, now on to trying to force my monitor (Predator XB27HU1) to display above 3x mode.

    Cheers,

    M

    #20004

    Braca862
    Participant

    I think the firmware update made the issue with the SNES even worse. The display now flickers constantly, making the SNES unplayable on my TV.

    #20011

    mrblack1
    Participant

    Hello, i just received my ossc, but how can i download the firmware ? impossible to downdload, the link doesn’t work ! help !

    #20015

    marqs
    Participant

    NES/SNES compatibility with certain displays seems to be affected by firmware versions despite no relevant RTL changes (Quartus always does full recompilation of the design, though). Timing constraints have been rewritten for the next fw which might help with good luck, but fixing the root cause is the only certain solution.

    #20016

    BuckoA51
    Keymaster

    Hello, i just received my ossc, but how can i download the firmware ? impossible to downdload, the link doesn’t work ! help !

    Not seeing any issues here what specifically isn’t working for you?

    #20017

    mrblack1
    Participant

    it’s ok i didn’t understand that it was the bin file that i have to download, but i have another big problem : my remote doesn’t work at all !!

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.