Menu

Horizontal Mask toggle

Home Forums OSSC OSSC – Feature Requests Horizontal Mask toggle

This topic contains 2 replies, has 2 voices, and was last updated by  Galdelico 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #16287

    Galdelico
    Participant

    Hi there, apologies for bringing this up again, but I’d be very interested to read Marqs’ opinion on this topic.

    My request is: would it be possible to include a proper H.Mask ON – OFF toggle, on top of the current numerical scale, in order to completely remove it?

    This is why I ask.
    As per the following pictures, I’m using Line2x optim. 320×240 mode on my Japanese Mega Drive 2. The screen is correctly centered, Advanced Timings are all good, Vertical Mask is set to 8 and Horizontal Mask to 0 (zero): I only cranked its brightness up to better demonstrate the issue I’m experiencing.

    This is what I get on the right side of the screen: https://i.imgur.com/e5vcUtk.jpg
    Alignment is perfect and beyond the last column of visible pixels begins the colored overscan (pink, in this very case, as I’m using The Super Shinobi). That white bar at the very bottom is the Vertical Mask brightened up to 15.

    Now, this is what happens to the left side: https://i.imgur.com/v5rUzaq.jpg
    As you can see, there’s still a hair of Horizontal Mask active by default, literally covering up half-pixel along the vertical border, even if it’s set to 0. If that line wasn’t there – hence my assumption that a proper toggle would fix the issue right away – the alignment would be as perfect as on the other side. No matter what I currently do with the Advanced Settings, I can’t get rid of it.

    Optim. outputs coupled with any other video mode (Line3, 4, 5x) seem fine. It’s just exclusive to Line Double.
    Of course, if there’s already a turnaround, any help would come super appreciated. 🙂

    Thanks in advance!

    — Edit —

    What I’m using:
    – unmodded Japanese Mega Drive 2 + Mega CD 2
    – standard Euro AV RGB scart cable (not a C-sync one, but with sync from composite)
    – Asus VG275Q 1080p monitor

    #16351

    marqs
    Participant

    I can take look into the original issue as it’s clearly a bug related to the special line2x implmentation. Not sure whether it’s feasible to add enable/disable option for the mask after getting that fixed.

    #16354

    Galdelico
    Participant

    Thanks for replying marqs. ^_-

    Should you find an easy way to fix the bug, then there would be no need for a toggle, as I suggested that only as an uneducated guess to get rid of that extra column of H. Mask to the left.
    Also, I don’t know if it’s actually an ‘extra’ column, or if the whole mask is just half pixel offset to the right… The only thing I checked out for sure, is that it’s impossible to move it out of the way. Even if I change H. sync-lenght/backporch and save the profile, as soon as I reload it, the column reappears.

    If you want me to test anything else and report, feel free to let me know anytime.
    In the meanwhile, thank you.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.