Menu

N64 Deblur Issue

Home Forums OSSC OSSC – Discussion and support N64 Deblur Issue

This topic contains 3 replies, has 3 voices, and was last updated by  ReallyDarkMagician 2 weeks, 5 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #16590

    ReallyDarkMagician
    Participant

    Hi all.

    Forgive my ignorance as I’m fairly new to the RGB scene. I was hoping someone here might be familiar with the issue I’m having.

    I have the latest Tim Worthington board equipped with the deblur toggle and I’m upscaling through the OSSC 1.6. The RGB signal looks great, but when I enable deblur, the screen tends to flicker pretty bad. If I disable deblur, the image on the screen is stable. I’m outputting on line 5x mode and I’ve tried the other modes to see if the issue persists, which it does. I’m a pretty big novice when it comes to the other settings and wouldn’t really know where to begin when it comes to fixing this issue. I got a new SCART cable from retrogamecables.com which is sync on luma to see if that was the issue, but I’ve seen no change there either.

    Any advice would be great. I love how sharp the picture looks with deblur enabled and if I could get the image to stabilize I’d have the perfect 64 setup. I can try and provide video evidence if it helps.

    Thanks!

    • This topic was modified 3 weeks ago by  BuckoA51. Reason: OSSC related question
    #16718

    BuckoA51
    Keymaster

    Can you tell us what the OSSC says on the LCD when you turn the de-blur on?

    #16721

    megari
    Participant

    Are you sourcing your sync from the N64RGB board? It has the pads CS75 and CS# for 75 ohm output impedance and TTL, respectively.

    #16755

    ReallyDarkMagician
    Participant

    So thankfully, it looks like the new cable has fixed the issue.

    My first initial use of the new sync on luma cable didn’t show any improvements. I still had screen juttering when deblur was enabled. However, I’ve been using it for two days now across multiple different games and I haven’t noticed those issues at all. I’m not sure if I messed with something in the OSSC settings or if the cable is just doing the job correctly now, but I believe the situation has resolved itself.

    Thanks for reaching out and I’ll report if there’s any changes.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.