Menu

No HDMI audio in line4x mode on Panasonic VT60 plasma

Home Forums OSSC OSSC – Discussion and support No HDMI audio in line4x mode on Panasonic VT60 plasma

This topic contains 7 replies, has 4 voices, and was last updated by  pva 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #15729

    pva
    Participant

    I received my OSSC v1.6 (FW v0.78) last week, and have been playing around with it since. The OSSC is connected to a Panasonic TC-P55VT60 (EU) plasma via HDMI. I’ve managed to get lineX3 (1280×768) and lineX4 (1280×1024) going with my Japanese Neo Geo AES (rev. 3-6) console using the instructions detailed in the LX3, LX4, LX5 tips & tweaks thread. Thanks, BonzoBits!

    However, I’ve noticed that while HDMI audio works flawlessly in lineX3 (320×240 optim. + a 16:9 aspect ratio on the TV) mode, it stays muted in lineX4 (320×240 optim./4:3 TV AR) mode. I’d prefer to use the lineX4 mode, since it results in a slightly better PQ.

    Is there a setting I should try tweaking on either the OSSC or the TV, or is this simply an incompatibility between the two? Or is it perhaps something that could be fixed in a future firmware release?

    #15735

    BuckoA51
    Keymaster

    It’s not unheard of unfortunately, we had another user say a similar thing happened on his monitor.

    #15738

    jonlad
    Participant

    Is this a display issue then?

    #15801

    pva
    Participant

    So it would seem. I tried connecting the OSSC to my Anthem AVR, and then connecting the AVR to the TV. In this setup, the HDMI audio worked fine in lineX4 mode, and the video signal was passed through to the TV unmolested as well.

    As a side effect, the display now seems to be a bit more finicky about the signal, though, and out-of-spec values will result in the video blacking out. I guess this is a result of the AVR subtly massaging the HDMI signal in some way. Not a huge setback as I already have everything dialed in.

    #15806

    BuckoA51
    Keymaster

    Very much in uncharted territory with the OSSC I’m afraid, it’s a unique product and you just have to try things and see what works sometimes.

    #15840

    BonzoBits
    Participant

    I had this problem after installing the audio board in a OSSC 1.5 and firmware 0.78. OSSC is connected direct to TV, using a SNES mini (borti’s RGB bypass board) and Lx4. Haven’t tried with other consoles.

    Fix is this. Switch the audio down-sampling setting from default to non-default setting, then back to the default setting. This should restore the audio. Basically ‘turning it off and on again’ or it might be the other way around. My OSSC is currently dead so I can’t fire it up to check if audio down-sampling default setting is on or off.

    Also, how good does the OSSC look on this TV? Does your VT60 show the OSSC image lower on the vertical axis than it should?

    #15880

    pva
    Participant

    I tried toggling the audio downsampling setting from ‘2x’ (48 KHz; the default) to ‘off’ (96 KHz) and back again in Lx4 mode, but sadly, this had no effect. Maybe the v1.5 with borti’s add-on board functions a little differently from the v1.6 in this respect.

    I’d say that in Lx4 mode the PQ is comparable to the Framemeister with FBX’s integer scaling profiles; that is, pin-sharp, but with less lag, of course. Lx3, on the other hand, seems a tad softer to my eye. And yes, if I change V. active from the initial 256 to 240 in order to restore the proper aspect ratio, the last line of pixels is cut off. (I’ve lowered V. synclen to 1 and V. backporch to 6.) If I leave V. active at 256, the picture is vertically centered, but slightly squished.

    Furthermore, the AVR seems to freak out if I lower V. active from 256, so it seems I’m going to have to go with a direct connection to the TV and Lx3 mode in order to get both audio and the proper aspect ratio (with a slightly cut-off bottom).

    • This reply was modified 1 month, 2 weeks ago by  pva.
    #16375

    pva
    Participant

    Just a quick update: Turns out someone else has had the same exact issue as me with their VT60 (except they’re using a Sega Saturn instead of a Neo Geo), and arrived at the same solution: Use Lx4 mode without HDMI audio, and run the sound from the OSSC’s 3.5mm mini jack to the AVR.

    http://whrl.pl/Re0Z6a

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.