Menu

No Signal (possibly related to sync issues?)

Home Forums OSSC OSSC – DIY Kit support No Signal (possibly related to sync issues?)

This topic contains 8 replies, has 3 voices, and was last updated by  Morpheus_79 4 days, 15 hours ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #12818

    Morpheus_79
    Participant

    Hi there. I bought the barebone DIY kit, the audio addon and all parts some weeks ago and managed to assemble everything over the last week. Well… almost everything – i couldn’t get my hands on a IRM-V538 IR receiver, since by the time i bought everything there was no seller available with this part in its stock. But i did get everything else, assembled it, flashed the latest firmware with audio support via JTAG connector and… have now some problems getting the OSSC to work properly.

    Without any input source connected i get a proper grey test pattern on my LG TV (42LM615S). But with my PAL SNES connected to the OSSC my TV simply tells me ‘no signal’ and just shows a black screen. Since it is a SuperCIC modded SNES i can switch between 50Hz and 60Hz output – but that won’t change anything at all.

    Maybe my TV has some incompatibility issues with the OSSC… and that’s the only problem (i couldn’t rule that out, since i don’t have any other screen to test… yet). But there’s some sync related strange behavior with the OSSC too. I made some videos to show what i mean:

    As those videos show: it doesn’t matter if my SNES outputs a 50Hz or 60Hz signal – i couldn’t convince the OSSC to get a stable sync to save my life. I tried different RGB cables… but: no change at all. I even tried to feed the RGB output of an old receiver and a DVD player to the OSSC – the results are the same: the LCD of the OSSC shows an occasional ‘NO SYNC’ and short flashes of different resolution/refresh rate values… and my TV continues to complain about ‘no signal’.

    To make bad things worse: since the IRM-V538 is still missing i can’t use the remote control to access the menu. So i don’t know if any fine tuning of the settings may help. But shouldn’t get the OSSC a stable sync from (at least!) ONE of the tested video sources “out of the box”!?

    Since at first there was a solder bridge on the pins 79 & 80 of the TVP7002, which prevented the OSSC from proper running, i’ve double checked every pin on every IC in hopes of finding something. But everything seems to be fine. So i’ve simply run out of ideas. Maybe someone reading this got one…

    #12823

    BuckoA51
    Keymaster

    Well the NTSC input is definitely being recognised wrong there, SNES should work out of the box and give you some kind of picture even on incompatible TVs.

    #12831

    Morpheus_79
    Participant

    Since the preview pic on the second video could be misleading -> for NTSC input most of the time it reads:

    AV1: RGBS 262p
    15.59kHz 59.53Hz

    But now and then it goes bonkers and shows something like:

    AV1: RGBS 532i
    15.59kHz 58.63Hz

    … or even:

    AV1: RGBS 995i
    15.59kHz 31.35Hz

    But since there was a solder bridge: could this issue be related to a possibly damaged TVP7002?

    #12860

    marqs
    Participant

    Please try another console if possible to ensure connection between TVP7002 and FPGA is working. 532i/995i do not look right indeed – that might be due to a cable issue or a certain bug that will be fixed in next fw.

    #12871

    Morpheus_79
    Participant

    I don’t have another console. But i’ll try to connect my old pc with the OSSC. Sadly i don’t have a VGA cable at hand but i will get hold of one.

    Hopefully it’ll work since i guess if it won’t, there may be an issue related to the TVP7002 or even the FPGA.

    #12891

    Morpheus_79
    Participant

    Update:
    Today i checked all pins of every IC under the microscope at work… but didn’t find any suspicious solder joint. Still: . Back at home i connected the OSSC with an old laptop via VGA and did some testing. Sync is unstable but existing. For whatever reason an output of 1280×720 is recognized as 746p… and 1280×800 as 828p. Sadly it doesn’t change anything for the HDMI output: my tv still shows ‘no signal’. I even replaced VGA and HDMI cables with different ones – but that didn’t enhance anything at all.

    Seems like i didn’t assemble an OSSC but just an expensive paper weight..

    #12896

    marqs
    Participant

    It sounds like FPGA is not getting sync signals from TVP7002, please check that HSYNC and VSYNC have connection between them (and scope the signals if possible). 746p and 828p are valid numbers since they include blanking lines.

    #12919

    Morpheus_79
    Participant

    Thanks for the clarification regarding the resolutions. I’ll test the connections of the HSYNC/VSYNC-OUT- and IN-Pins between both ICs tomorrow. Sadly i don’t own any scope to check for proper signals… but maybe i can borrow one from work.

    #12942

    Morpheus_79
    Participant

    I checked the connections: TVP7002/Pin23 -> EP4CE15E22/Pin91 & TVP7002/Pin24 -> EP4CE15E22/Pin90 are perfectly fine. I resoldered them nonetheless… but it didn’t change anything. I wasn’t able to get my hands on a scope… so i couldn’t check the signals. I would assume: either the TVP7002 is damaged spits out some corrupt sync signals or the FPGA does something wrong interpreting them?? But without scoping the signals between the digitizer IC and the FPGA no one can say for sure??? Am i right or am i wrong? Any suggestions for what else to test?

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.