Menu

Optimized modes

Home Forums OSSC OSSC – Discussion and support Optimized modes

This topic contains 6 replies, has 6 voices, and was last updated by  BonzoBits 4 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #13971

    Jeruro
    Participant

    I have been looking for the use of optimized modes but i can’t find a clearly answer. What is the purpose of these modes? When i select it i can only see a badly and blurry image compared to the normal mode.

    #13972

    BuckoA51
    Keymaster

    They allow you to use timings that are tightly optimised for certain consoles native resolutions. If you use them with the wrong console it will look blurred. See http://junkerhq.net/xrgb/index.php?title=Optimal_timings

    #14137

    olsenn
    Participant

    With my SNES hooked up to my Vizio M65-C1 TV, when I switch from LIne-3X mode to Line-5X mode (both set to 4:3 aspect ratio in the Output Options menu) the aspect ratio changes (becomes stretched horizontally in Line-5X mode). Changing the aspect ratio option from 4:3 to 256×240 makes the image look low-resolution and botchy. Actually even switching the video output between HDMI and DVI causes the image to change aspect ratio and clarity (I figured sound was the only difference between the two)

    Can you explain why changing line multiplication mode affects the aspect ratio instead of just the sharpness? What settings are recommended for SNES (in DVI mode)? I don’t understand all the settings involving clocks and phase-locked-loops and offsets, etc. So complete listings of every setting that needs to be changed from factory default would be helpful!

    #14141

    Harrumph
    Participant

    If you mean in generic 4:3 mode, it could be because the Horizontal Active area is 1536 in Lx5, which is an irregular number, and your display feels it needs to stretch this for some reason. For “regular” 16:9 & 4:3, H.Active would be 1920 & 1440, respectively.

    The other reason is that in Lx5, the top and bottom is cut off, showing only 216 of the original 224/240 lines. Do note that this shouldn’t appear stretched really, more like it is zoomed in.

    Edit: realised it could also be like my old TV, where I had to reduce samplerate. In that case, a samplerate around 1950 should be ideal. Then reduce H.backporch and (possibly) H.sync as needed.

    #14161

    BonzoBits
    Participant

    For correcting the blurry picture, the following applies for my Panasonic VT60. It’s a bit of a pain, but will give the highest quality output. Much cleaner and sharper than generic modes at least.

    1) Set output mode to Lx3/4
    2) Set linemulti output mode to optim 320×240
    3) Go to sampling options
    4) Scroll down to 320×240 optim
    5) Might need to use Harrumph’s trick to get an image to appear on screen. Involves increasing V.active to 256, then reducing V.backporch until you get a stable image. Firmware 0.76 required a setting of 6, 0.77 requires a setting of 2 or 3.
    6) Now you can play around with H.samplerate to try and get the graphics looking all a smooth and crisp. Basically, just keep incrementing H.samplerate by 1 until everything becomes sharp. As examples, Sega Saturn 320 mode games require a bump up to 427 or 428. Non-320 modes require a setting of 455. Panzer Dragoon 1 is an example, capcom fighters also.
    7) If you used step 5 to obtain a picture, final step is to restore correct AR. Do this by reducing V.active back down to 240.

    My understanding is that the H.samplerate adjustments are not compatible with all displays.

    #14165

    marqs
    Participant

    @olsenn @harrumph: By default both generic 4:3 and 256×240 line5x modes have 1920×1080 active area as seen by display: the sides are padded with black bars and top/bottom of the source are cropped a bit (“Line5x format” setting can be used for switching to full 1200p output). The aspect ratio in generic 4:3 modes should be equal regardless of linemult mode, but in 5x (1080p format) the vertical cropping may slightly affect that.

    256×240 modes usually need sampling phase adjustment, see the wiki for details.

    Selection between DVI and HDMI should not affect the aspect when using line3x or higher, maybe the TV has different processing path for “PC / DVI” video. You may try toggĺing “HDMI ITC” (while using HDMI TX mode) option to see if it improves clarity.

    #14174

    BonzoBits
    Participant

    Hey Marqs, for displays that don’t recognise Lx5, are there any adjustments that could be made to fix this. IE, something like the adjustments needed for Lx4/5 on certain displays?

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.