Menu

Does the OSSC add audio to HDMI when audio input is disconnected?

Home Forums OSSC OSSC – Discussion and support Does the OSSC add audio to HDMI when audio input is disconnected?

This topic contains 10 replies, has 7 voices, and was last updated by  Harrumph 3 weeks, 2 days ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #16506

    nmalinoski
    Participant

    Greetings! I just received my OSSC 1.6 today, got it all hooked up, and it seems to be working well except for one small audio issue.

    A simplified version of my setup (Which I just tested):
    – Onkyo TX-NR555 receiver: HDMI4 and OPTICAL1 associated with the GAME input.
    – OSSC 1.6: HDMI to HDMI4 on receiver; SW4? set to AV2-in (if this matters)
    – PS2 30000 series: component video to OSSC; optical audio to OPTICAL1 on receiver

    With this setup, I expected, with no audio connected to the OSSC, that I’d be able to get video over HDMI and audio over optical. According to the manual (and I verified this in the Audio Selection settings), the receiver is supposed to prefer audio from HDMI, and then fall back on the other audio inputs when the HDMI signal doesn’t have audio.

    Unfortunately, what happens is I get no audio. (Video is fine.) If I disconnect HDMI, or if I change the preferred audio input from HDMI to Optical, then I get audio. I’m not sure whether the issue lies with the OSSC or the receiver. (I’ve emailed Onkyo for clarification.)

    So, how is the OSSC handling audio, and how should it be handling audio? Is it always adding an audio signal to the HDMI-out, even when nothing is connected to the corresponding audio inputs? Or does it stop injecting audio when that input is disconnected?

    #16512

    Teddy Rogers
    Participant

    It shouldn’t matter if there is audio over HDMI or not, your audio selection on your Onkyo receiver is what matters. You can confirm if there is an audio stream over HDMI by checking “Source Information” on your receiver. Have you tried connecting the HDMI cable to the GAME input (I think this is HDMI3) on your receiver and have the optical cable plugged in to OPTICAL1 of the receiver? From memory this is the default configuration for Onkyo’s. I’d then go to Source Information to make sure everything is correct…

    Ted.

    • This reply was modified 3 weeks, 4 days ago by  Teddy Rogers.
    #16515

    nmalinoski
    Participant

    Have you tried connecting the HDMI cable to the GAME input (I think this is HDMI3) on your receiver and have the optical cable plugged in to OPTICAL1 of the receiver?

    This sounds like what I’ve described my setup as–the HDMI and optical ports I’m using are both assigned to the Game input, and I can successfully toggle between HDMI and optical audio by adjusting the Audio Selection setting.

    With no audio connected to the OSSC, and optical connected to the receiver, the information button (Which, sadly, only seems to show info on the receiver’s display, not the TV) reads AllCh:Stereo and PCM 2.0; so the OSSC is putting out an audio signal regardless of what it has for input?

    It shouldn’t matter if there is audio over HDMI or not, your audio selection on your Onkyo receiver is what matters.

    Why shouldn’t it matter? Audio over HDMI should trump audio over other inputs, and, should there not be audio over HDMI, the next-best available audio input should be used. That’s not happening here, because there seems to be a phantom audio signal on HDMI preventing the receiver from falling back on optical.

    #16516

    Teddy Rogers
    Participant

    Unfortunately I don’t have an Onkyo receiver anymore to test. Have you selected priority for the input for when there are multiple audio sources? You probably need to remove it from auto. Have you also checked you are using the correct listening mode?

    Ted.

    #16519

    BuckoA51
    Keymaster

    Why shouldn’t it matter? Audio over HDMI should trump audio over other inputs, and, should there not be audio over HDMI, the next-best available audio input should be used.

    I don’t think most AV receivers are clever enough to do this, certainly our Onkyo isn’t.

    #16522

    paulb_nl
    Participant

    You can flash the firmware without -aud. Then the OSSC should not output any audio through HDMI.

    #16527

    nmalinoski
    Participant

    Have you selected priority for the input for when there are multiple audio sources? You probably need to remove it from auto. Have you also checked you are using the correct listening mode?

    The priority setting, “Audio Select”, is set to HDMI; however, this setting only seems to control which audio input is used rather than any kind of priority. There is no “Auto” value available for me to switch away from–there is only HDMI, optical, and analog as choices.

    You can flash the firmware without -aud. Then the OSSC should not output any audio through HDMI.

    I would, but this is undesirable. Ideally, I would have, from my component AV switch, RCA audio running into the OSSC, and then optical audio running into the receiver, and whichever is connected would work (I took the switch out of the equation when reporting this; it may very well cause its own issues).

    #16551

    megari
    Participant

    I don’t think it should be too difficult to add a feature to the firmware that allows to disable the audio output using the remote. Too bad the “Mute” button on the default remote is already mapped to something else.

    #16562

    marqs
    Participant

    Setting TX mode to DVI should disable digital audio output.

    #16586

    nmalinoski
    Participant

    Setting TX mode to DVI should disable digital audio output.

    Changing TX mode to DVI causes my receiver to fall back to optical audio as I hoped; unfortunately, this setting is somewhat buried in the menu; and, as megari noted, the mute button is already mapped to something else.

    I suppose it’d be too complicated to try to detect whether there’s an audio signal (versus simply detecting whether a cable is connected, which is easy); might just be simpler to ask for support in the firmware to have the mute button toggle the audio, or wait for a TOSLINK-enabled OSSC (if one should ever arrive).

    #16593

    Harrumph
    Participant

    TX mode is saved by profile, then it’s easy to switch between.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.