Menu

Problems with OSSC and PS2

Home Forums OSSC OSSC – Discussion and support Problems with OSSC and PS2

This topic contains 9 replies, has 3 voices, and was last updated by  paulb_nl 3 weeks, 3 days ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #9582

    Kenny8215
    Participant

    Hey,
    today I got my OSSC. I hooked it up to my PS2 and my TV and turned it on. But the TV screen remained black. It’s a PAL PS2 and I used a PS1 game. The PS2 is connected via a RGB scart cable and the sync LED is not red. As soon as I switched the Lx3 option on, my tv said “picture mode not supported”. After that I tried my Wii with a component cable and that works perfectly. My TV is a Phillips 32PFL6606K/02. And I also tried the same with the PS2 and my Computer Screen, that also does not work.

    I hope someone can help me.

    #9583

    BuckoA51
    Keymaster

    Do you get a picture with the PS2 when no game is inserted and it’s just on the dashboard?

    #9585

    Kenny8215
    Participant

    No, nothing.

    #9587

    paulb_nl
    Participant

    Have you tried another console with scart?

    #9588

    Kenny8215
    Participant

    The only other console I have right now is the PS1 and I think the output of the PS2 with a PS1 game is the same as the PS1. My TV still has a scart port and I get a picture from the PS2 over that port, so its definitely not the fault of the console.

    #9589

    paulb_nl
    Participant

    Alright. Trying another console was meant for ruling out a problem with your scart cable or with the OSSC. Which RGB scart cable are you using? Some scart cables marked as RGB are not actually wired for RGB.

    #9590

    Kenny8215
    Participant

    I’m using the original cable and scart adapter that came with the ps2.

    #9591

    paulb_nl
    Participant

    Well thats the problem. The original cable with scart adapter is not RGB but composite video only.

    #9593

    Kenny8215
    Participant

    Well, now I’m feeling stupid 😀 All those years I thought that was a RGB cable. Thanks for the tip.^^

    #9597

    paulb_nl
    Participant

    Then you have been missing out! 🙂

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.