Menu

Saturn audio hissing

Home Forums OSSC OSSC – Discussion and support Saturn audio hissing

Tagged: , ,

This topic contains 24 replies, has 7 voices, and was last updated by  BuckoA51 9 months, 2 weeks ago.

Viewing 10 posts - 16 through 25 (of 25 total)
  • Author
    Posts
  • #18406

    BuckoA51
    Keymaster

    Ok, I’ll have a rummage in the attic and see what units I have access to, also try them without the Extron Crosspoint in the chain see if that makes any difference.

    #18410

    SirRockALot
    Participant

    Looking at the pictures I took of my Saturn when I installed the modchip and comparing them to the GDemu site pictures, I have a VA7-9, no audible noise / hiss.

    This could be fixed with a relatively simple LPF circuit, right? Might make a fun project if I ever have that issue on the OSSC.

    Hey professor, would be amazing if you and Matt could work together on manufacturing. If you’re ready before Brexit I could avoid dealing with customs completely 😉

    #18418

    BuckoA51
    Keymaster

    We’re looking at relocating to stay in the EU single market so hopefully Brexit won’t be a problem with regards to that (unless you’re in the UK in which case, well, innovative jams and all that eh?)

    #18489

    marqs
    Participant

    @prof_abrasive how far beyond 50kHz was the noise still significant? I could easily double PCM1862’s internal sampling rate to 192kHz which should mitigate aliasing noise up to ~100kHz.

    #18490

    prof_abrasive
    Participant

    I tried putting a cap in parallel with the output. Conveniently, you can attach caps to ground via the AV1 OUT jack with the switch in the out position.

    From the schematics the output impedance is about 1040Ω, so a 6.8nF cap puts the cutoff frequency at 22.5kHz, which shouldn’t have a noticeable effect on audio quality. This helps a lot, but it’s still fairly noisy. Increasing the cap would help a bit, but at some point it’s going to start cutting in to the audible range.

    Ultimately the filtering problem will never be adequately solved with an RC filter; the difference between the passband (20kHz) and the noise/stopband (50kHz) is too small to get good attenuation. An active filter is required, which means op-amps, power, etc. Messy.

    #18491

    prof_abrasive
    Participant

    @marqs it goes way, way up.

    Still, with an added RC pole around 20kHz, that might net another 6dB.

    #18517

    zaxour
    Participant

    I’m having this same issue on my Japanese Saturn (not sure which model, it’s off-white with a fuchsia eject button), but on my broken model 2 US Saturn, the noise is not there (disc drive doesn’t work). Interested to see if there’s any solution. My J-Saturn previously did not do this!

    #19799

    Gummi
    Participant

    I just did some quick testing of the new OSSC 0.80 firmware and I’m happy to report that it appears that it has fixed the audio hiss on my Saturn! Thanks Marqs!

    In my excitement to test this out I forgot that all your settings get wiped in the update process… serves me for not having written up all my optimized settings before.

    #19820

    prof_abrasive
    Participant

    Fixed here too. Fantastic! Thanks very much @marqs. Did you end up doubling the internal rate or was it something else?

    Thanks also for providing JIC files, I couldn’t get it to accept the image off any of the three SD cards I tried 😐

    #19827

    BuckoA51
    Keymaster

    Excellent news 🙂

Viewing 10 posts - 16 through 25 (of 25 total)

You must be logged in to reply to this topic.