Menu

SCART audio not being injected into hdmi

Home Forums OSSC OSSC – DIY Kit support SCART audio not being injected into hdmi

This topic contains 4 replies, has 3 voices, and was last updated by  vgdiy 4 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #14355

    vgdiy
    Participant

    I got around to getting my 1.6 ossc fixed but now I notice that im not getting any audio through the hdmi cable when using a SCART cable. I do get audio out of the J6 analog 3.5mm audio jack when using SCART. Does anyone have any ideas?

    #14356

    Morpheus_79
    Participant

    Getting analog sound over the 3.5mm jack doesn’t say much, since SCART-audio-in and 3.5mm-audio-out are directly connected, when switch SW4 is on the right position. At least it is a good indicator, that audio is sent in.

    Since your oscillator was soldered the wrong way around, you should take a look at U8. It’s the audio A/D converter. The round indentation on one of its corners should face towards the HDMI connector. If it faces towards the SCART Connector, it was soldered wrong too.

    If U8 was soldered right, you should check its solder joints and the joints of oscillator Y2.

    Keep in mind: you need the audio enabled firmware (the one with the -aud in the filename) flashed onto the OSSC for the audio A/D converter to work! Since my own OSSC 1.6 is still in the works, i don’t know the following for sure: if you already use the last audio enabled firmware without any luck, you maybe(???) need a special audio enabled firmware for the new PCM1862 A/D audio converter chip (since the audio addon board for the OSSC 1.5 uses a different chip without its own oscillator). But i could be wrong.

    #14359

    marqs
    Participant

    If you’ve flashed the firmware yourself, then you’ll need to build the latest code on github which includes support for PCM1862. It will be included officially in v0.78 release that I’m planning to publish next week.

    #14362

    Morpheus_79
    Participant

    ‘Borti4938’ said, he included the support for the PCM1862 in his latest 0.77 build. So if you didn’t want to wait a few days for the official release, you could use his ossc_0.77-aud.jic or ossc_0.77-aud.bin from here:

    https://github.com/borti4938/Audio4OSSC/tree/master/fw-builds

    #14374

    vgdiy
    Participant

    ossc_0.77-aud.bin did the trick, audio is working great. thanks everyone

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.