Menu

Scart Switchers

Home Forums OSSC OSSC – Discussion and support Scart Switchers

This topic contains 5 replies, has 3 voices, and was last updated by  chrid 3 weeks, 2 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #14815

    chrid
    Participant

    So I recently finally received my ossc 1.5 and I have been trying to run it through my hydra scart switch. Whenever I plug it in I get nothing and the ossc just says no sync. I have tried it with sync on Luna and a c sync cable from my Saturn’s. They hydra seems to detect the signal as the led’s stop at the powered input but nothing comes through. I have also tried two male to male scart cables between the hydra and the ossc. Hope I’m just a noob amd doing something stupid here, and ideas? Cheers.

    #14816

    Harrumph
    Participant

    Have you selected the input (i.e. AV1 for Scart) on the OSSC?
    The quick-start guide might help you. https://www.videogameperfection.com/support-files/ossc-quickstart.pdf

    #14817

    chrid
    Participant

    Yes I’ve cycled through all the inputs. It works fine when I’m plugged directly into the ossc.

    #14818

    BuckoA51
    Keymaster

    The hydra worked just fine for me, weird. Does your Hydra work connected directly to a display?

    #14820

    chrid
    Participant

    Unfortunatly I have no other current way to input through scart. I might try to get a scart to component adapter tomorrow to test it out. I’ve had the hydra for a couple of months now as I was preparing for the ossc. If it’s faulty I’ve heard the manufacturer. Is pretty good with returns, I just can’t think of what else it could be.

    #14833

    chrid
    Participant

    All good now. Narrowed it down to a dud usb power supply. Its working perfectly now. Thanks trying to help. ☺

    • This reply was modified 3 weeks, 2 days ago by  chrid.
Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.