Menu

Super Famicom loses sync on 2x mode

Home Forums OSSC OSSC – Discussion and support Super Famicom loses sync on 2x mode

This topic contains 5 replies, has 3 voices, and was last updated by  Hypetreme 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #18615

    Hypetreme
    Participant

    My SFC is equipped with a csync cable and I noticed that most of the games played with it lose sync (black screen) from time to time. When it does this, before going black some thin red lines will flash on the screen too. It usually depends on what part of the game is being played. This problem ONLY appears on 2x mode 4:3 all other modes work just fine. I tried to play with the h. samplerate and actually got it work, but then a big chunk of the screen is cut. Also tried basically everything else possible. I don’t remember having this problem with a PAL SNES.

    #18618

    paulb_nl
    Participant

    Does the OSSC lose sync (red light on or Hz changing) or only your TV? This might be related to the sync jitter on NTSC SNES. PAL SNES only have sync jitter with interlaced mode.

    Is it a 1-CHIP SFC? Can you post the link to the CSYNC cable?

    #18619

    Hypetreme
    Participant

    OSSC is not losing the sync, in fact it’s only the TV. If my memory serves me right, I think I purchased the cable from Consolegoods.co.uk. I can’t actually say for sure if it was a one with CSYNC or not. the SFC is not a 1-CHIP model. Should I try a CSYNC cable from retrogamingcables or are there some other tips for adjusting the settings on OSSC? For clarification, this problem only persists with 2x mode.

    #18637

    paulb_nl
    Participant

    If its only the TV that loses sync then its most likely the sync jitter from the SFC although its weird that it only happens on line2X.

    Try a different display and also try to use your PAL RGB cable on your SFC to see if it still happens.

    When you changed H.samplerate did you also change H.active? If your TV supports H.active then it will change the screen width.

    #18643

    Halash
    Participant

    Hi Good day, I’ve had a few issues with sync with my NTSC SNES on the OSSC also my cable was CSYNC and I also had one with Sync on Composite in some cases that gave me some jitter on the screen and even some audio and Sync issues, What I could recomend you is getting a “Sync on luma” cable I had no issues with my OSSC or Sync after I change my cable.

    If you have the Skills you can change a “Sync on Composite” cable to a “Sync on luma” easily.
    But You can also just buy the cable online as far as I know this helped me a lot and I havent had any issues since then.

    PD. Make shure your cables are shielded becasue sometimes that can affect the video and audio quality of the image/sound.
    Also check if the cable is loose or somethin inside, That also happend me once with a saturn cable.

    #18646

    Hypetreme
    Participant

    Well, I actually got it work while I spent more time tweaking the advanced timings. Now there’s no screen cut out and it also works with Elgato HD. If anyone else is having this problem with their TV, here are my settings for my Samsung TV PS43F4505:

    H.backporch 59
    H.active 720
    v.synclen 5
    V.backporch 19
    V.active 240
    H.samplerate 920
    H.synclen 97

    EDIT: Here’s some video footage just for fun https://www.dropbox.com/s/dd7794avggpw0s0/contra.flv?dl=0
    download it for 60fps playback.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Finland