Menu

Turbo Chameleon support

Home Forums OSSC OSSC – Discussion and support Turbo Chameleon support

This topic contains 7 replies, has 3 voices, and was last updated by  sprudel79 2 months, 2 weeks ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #11225

    sprudel79
    Participant

    Hi all,

    I would like to ask if anybody was able to use the Turbo Chameleon together with the OSSC.
    I am talking about that one:
    http://amigastore.eu/en/251-chameleon-64.html

    The Turbo Chameleon can be used either as a C64 cartridge or standalone.
    When using it in a standalone manner there’s a VGA out provided at the cartridge.
    So just for fun I was trying to connect it to the OSSC. On the OSSC display I was able to see some activity on the VGA IN port but I wasn’t able to see anything on my TV.
    Does anybody else tried to use the Turbo Chameleon in the same way and could assist?

    Thanks in advance and best regards,
    Thomas

    #11231

    BuckoA51
    Keymaster

    Can you let us know what the LCD displays when you try to use it?Also what is shown when you press the info button?

    #11307

    sprudel79
    Participant

    Hi,
    sorry for the late reply.
    Here’s the information what the display is saying:

    AV3: RGBHV 874p
    52.63kHz 60.21Hz

    Pressing Info button will show this:
    VMod: 1280×1024
    LO: 874 VSM: 0

    Thanks!

    #11353

    BuckoA51
    Keymaster

    Well, that’s definitely not right. Hmm.. can you try switching to another active input then back to VGA again?

    #11359

    marqs
    Participant

    The cart is probably outputting 1024×768 – right? OSSC excepts VESA timings (806 lines for 1024×768@60), but since 874 is too far from that it picks next mode (1280×1024) from the list. With 1280×1024 parameters, V.active ends up being too high to properly show on display. You’ll need to access adv.timing and copy 1024×768 parameters into 1280×1024 mode to fix this.

    #11651

    sprudel79
    Participant

    Hi,
    sorry for my late reply and many thanks for the replies.
    But yesterday I had a chance to test this again. First, I updated to latest firmware 0.76.
    There was no change in the behaviour.
    @marqs: “You’ll need to access adv.timing and copy 1024×768 parameters into 1280×1024 mode to fix this.” -> how can I do this? I was playing around with the menu in order to change some parameters (without any impact). Where do I need to apply your fix exactly?

    The Turbo Chameleon itself can be configured to produce different outputs (I think default mode is 800×600@72Hz). So it’s worth trying to change the output there as well.

    Best regards,
    Thomas

    #11706

    marqs
    Participant

    Adv. timing is found under sampling options. First select 1024×768 from the list via < -/-> buttons and write down all parameter values, then go back and select 1280×1024 and replace the values with the written down ones.

    #11732

    sprudel79
    Participant

    Hi,

    I have solved it by trying different settings directly in the Turbo Chameleon setup.
    Since it’s offering approx. 10 different video modes I was able to find a few that work also with the OSSC!
    The video mode I think is definitely the best is 640×480@60Hz.

    Many thanks for your support and best regards,
    Thomas

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.